После обновления на Firefox 57 что-то пошло не так, решение

После обновления на Firefox 57 что-то пошло не так, решение

Ночью обновился Firefox на 57 версию, по времени UsA это было ещё 29 сентября.

При попадания фокуса jaws 18 в окно firefox вылетает сообщение:

Показ содержания вкладки отключен из-за несовместимости между Firefox и вашей программой поддержки доступности. Пожалуйста, обновите ваше средство чтения с экрана или переключитесь на версию Firefox ESR.

Покупать на AliExpress получая Cashback или даже зарабатывать

Какая проблема возникает?

После чего окно браузера Firefox перестаёт озвучиваться, хотя меню остаётся доступным. Таже ситуация происходит и в разделах настроек и дополнений.

Кроме этого удаляются все расширения и происходят прочие радости.

Что можно сделать?

Разработчики Mozilla, рекомендуют пользователям скринридеров перейти на коммерческую версию Firefox Esr.

Mozilla Firefox ESR 52.4.0 (Возможно есть версия и новее, но мне не встретилась.)

Версия браузера с расширенным сроком поддержки.

Сам же я решил просто откатиться на предыдущею версию 56, а затем полностью отключить автоматическое обновление.

Для отката, просто установите Firefox 56 по верх версии 57 и все расширения вновь будут работать, а окно браузера будет доступным для Jaws 18.0.4104.

Прямые ссылки на инстоляторы Firefox

А это для тех кто желает попробовать Firefox Esr 52:

Если не работают прямые ссылки!

Для пользователей программы экранного доступа Nvda после обновления firefox с версии 56 на 57 не чего не изменилось.

Кроме этого, можно перенести профиль из стационарной версии Mozilla firefox 57 в портативную версию 56, портативную сборку Firefox Hybrid. и продолжить пользоваться привычным браузером. Скорей всего в следующем обновлении Jaws 2018.1 браузер Firefox 57, Firefox 58 и Firefox 59 будут уже вновь доступными для пользователей вспомогательной программы экранного доступа Jaws.

Хотя рано или поздно всем нам придется следовать ветру перемен и осваивать новое, а это всего лишь временная отсрочка.

Дополнительные наблюдение от 13 Октября

Чтобы не вводить в заблуждение пользователей программы Jaws, решил дописать эти строки.

Попалась мне портативная версия Firefox 58 Nightly. Проведя тест на совместимость с Jaws 18.0.4104, обнаружил что мои первоначальные выводы были преждевременными. Сайты нормально открываются, на первый незрячий взгляд всё в рамках допустимого.

Единственное что постоянно бросается на слух: это при открытии новых вкладок, перехода между вкладками, обновления страниц во вкладке всплывает выше описанное предупреждение, но пользоватся браузером это не особо мешает.

А вот с расширениями полная беда, все излюбленные и привычные дополнение не работают.

Исходя из этих наблюдений, выходит что и в последних бета обновлениях Firefox 57, было всё примерно также.

Но всё же, тем кому необходимы привычные расширения для Firefox, могут следовать моим действиям по откату и отключению обновлений.

С уважением к вам, Валентин Куприянов автор блога.

проверка доступности сайта

< Яндекс.Метрика